[buug] Can't get Linux to see more than 2 GiB on 75GXP

Patrick Soltani psoltani at ultradns.com
Thu Dec 20 09:06:37 PST 2001

Is the drive scsi or IDE?
If ide, then have you checked the LBA, Logical Block Addressing, in the
I have run into situations that simply instructing the bios to handle
the ide disk with LBA enable resolves the size problem.
If scsi disk, then I would do a low level format of the scsi device.
Usually the adaptor allows you to do this via a key-stroke/menu or the
manufacturer has a utility that you run off of a floppy, usually DOS
based, and takes care of this.

Good luck.

Patrick Soltani.

-----Original Message-----
From: Will Sargent [mailto:will_sargent at yahoo.com]
Sent: Thursday, December 20, 2001 1:56 AM
To: buug at weak.org
Subject: [buug] Can't get Linux to see more than 2 GiB on 75GXP

I throw myself on the mercy of the mailing list.  I have RTFM'ed to the
depth of my understanding, and I'm still hosed.

I can't get my IBM Deskstar 75GXP to be recognized as more than 2 GiB
Linux.  I'm using the 30 GiB model (IBM-DTLA-307030).  I've tried
8.1 and Redhat 7.1, and both distros will come up on boot recognizing
drive type, but then assigning it as a 2 GiB drive.  The CHS is printed
255/255/63, if CHS still has any meaning.

I'm using an Asus A7V133 motherboard, revision 1004.  This drive and
motherboard worked fine for me under Windows 2000 (so it's not a bad
or outdated BIOS (which is unlikely).  The Asus board includes an
Promise ATA/100 controller, and I've tried using that instead of the
standard ide channels, but that doesn't seem to help (again, it
the drive on /dev/hde, but has the wrong CHS and number of sectors).

I've even tried specifying the CHS directly using bootparam.  The
line I'm currently using is:

linux ide2=0x9400,0x9002,autotune hde=3737,255,63

which at least forces hdparm -g to show the right CHS, but still doesn't
change the number of sectors (i.e. it still thinks it's a 2 GiB drive).

I don't have anything wierd in my system that I know of.  There's a
Tulip type ethernet card and a SB Live soundcard.  I also have the 50x
CD-ROM drive plugged into ide2 so it gets recognized by the BIOS and can
boot up (although it's still a secondary slave).

Anyone who knows whats happening here shall receive my eternal


Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

Buug mailing list
Buug at weak.org

More information about the buug mailing list