[buug] Updating ports using cvsup

Miki Shapiro aris at pharoe.com
Mon Dec 31 02:44:51 PST 2001


Hi all
I have a FreeBSD 4.4 Release box installed from a mini distribution, with
the ports collection.
I went into /usr/ports/net/cvsup and did a "make install"

Now I want to update my ports collection. I took the default cvs_supfile
from the /usr/share/examples/cvsup directory, changed it to local settings
and ran as in the handbook. It worked for a long while, then I had
/usr/ncvs the relevant subtrees (src, ports, doc) full of files with ",v"
appended to them.

The whole procedure seems to have ended successfully.

That's where the handbook just left off, and my /usr/ports is still not
updated. I haven't the slightest clue what to do with all the new tree
under ncvsup. (or how to convert those ,v files into what they're really
supposed to be)

1. What do I do now? (some FM to RT would be wonderful)
2. Should I at some point remove the old /usr/ports and replace it with (a
softlink to) /home/ncvs/ports ?
3. Where is updating the whole operating system (make world I think?)
documented in a step-by-step guide?
4. When, regardless of the whole cvsup updating procedure, I go into
/usr/ports/editors/pico and run "make install", where is the downloaded
package saved on disk?

Thanks a bunch!

--
Miki Shapiro <aris at pharoe dot com>
Unixophilic Software Developer
---------------------------------------------
Tel: +972-(56)-322433  ICQ: 3EE853
---------------------------------------------
If at first you don't succeed...
... SkyDiving is probbably not for you.





More information about the buug mailing list