[buug] FreeBSD Linux Compatibility problem

Patrick Soltani psoltani at ultradns.com
Thu May 8 18:09:40 PDT 2003

This usually works on 4.x, haven't tried 5.x though:

brandelf -t Linux linux-program

Patrick Soltani.

>-----Original Message-----
>From: Erick Smith [mailto:desertfox at cableaz.com]
>Sent: Thursday, May 08, 2003 5:25 PM
>To: buug at weak.org
>Subject: [buug] FreeBSD Linux Compatibility problem
>I have a Linux app that's in RPM format that I'd like to 
>install and run using 
>FreeBSD's compatability layer.
>I'm running into a couple of problems though.
>First, the RPM won't unpack unless I turn dependencies and the 
>OS check off.
>After the RPM is unpacked, the installation script runs fine.
>When I try to run the app though, it checks the OS type and 
>finds FreeBSD 
>instead of Linux and refuses to run.  I tried to hack a 
>symlink into the 
>Linux file tree so that the app would see Linux when it does 
>it's OS check, 
>but then it can't find all the necc. libraries.
>What I'd like to know is if there's a way to tell the 
>installed app to use the 
>Linux compatability layer, i.e. is there a way to designate an 
>app as a Linux 
>app not a FreeBSD app?
>Alternatively is there a way I can unpack and install the app 
>that preserves 
>the Linux flag so the app automatically knows it's Linux not FreeBSD?
>Thanks for any insight.  I have gotten other Linux apps to 
>work under FreeBSD, 
>but not from RPM's.  I'm running FreeBSD-5.1-CURRENT
>Buug mailing list
>Buug at weak.org

More information about the buug mailing list